Back to overview
Maintenance

Scheduled Maintenance & Infrastructure Relocation

Feb 10 at 06:25pm EET  –  Feb 10 at 07:25pm EET
Affected services
Imperial API
Landing page
Imperial Dashboard

Resolved
Feb 10 at 08:11pm EET

Maintenance has been completed and services are now operational.

We will continue monitoring all systems closely to ensure full stabilization and performance.

Updated
Feb 10 at 07:50pm EET

Almost done! We're at the final steps of the re-location.

Updated
Feb 10 at 07:27pm EET

We are now setting Imperial up on the new machine.

Services remain unavailable during this process. No user data is affected, and further updates will be shared as progress continues.

Updated
Feb 10 at 06:26pm EET

The relocation of Imperial’s internal infrastructure has now started.

As a result, services will be unavailable until further notice. No user data is affected, and updates will be provided as progress continues.

Thank you for your patience.

Created
Feb 10 at 06:25pm EET

We will be performing routine system maintenance to ensure everything remains secure, up to date, and running smoothly.

At the same time, we are beginning the relocation of Imperial’s internal infrastructure. This is a planned process and part of ongoing improvements to reliability and performance.

During this period, a small percentage of users may experience limited access to the dashboard or temporary unavailability. No user data is affected, and services are expected to return to normal shortly after completion.