Back to overview
Maintenance

Scheduled database infrastructure maintenance

Jun 4, 2026 at 8:40pm UTC  –  Jun 4, 2026 at 9:32pm UTC
Affected services
Imperial API
Landing page
Imperial Dashboard

Resolved
Jun 4, 2026 at 9:32pm UTC

The planned database maintenance is done. Imperial's database now runs on dedicated infrastructure, so reads and writes across uploads, embeds, the API, and the dashboard are noticeably faster. No action is needed on your end — thanks for your patience.

Updated
Jun 4, 2026 at 9:32pm UTC

Maintenance ended

Updated
Jun 4, 2026 at 8:55pm UTC

We're migrating user data over to the new database.

Updated
Jun 4, 2026 at 8:44pm UTC

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Created
Jun 4, 2026 at 8:40pm UTC

We're performing scheduled maintenance on core parts of our database infrastructure. This work keeps our systems redundant and improves performance across all areas of Imperial.

Services will remain available throughout the maintenance window, though you may experience occasional brief interruptions. All data is safe and will remain fully intact.

Expected duration: 30 minutes – 1 hour

We'll update this page as things progress.